The installation manual for Linux Agent PAM 3.5 states that

"When you are installing PAM agent in SLES 12 or later, ensure that LSB (Linux Standard Base) version 3.0 or later is installed."

It seems that lsb is mandatory dependency for the agent. At least in our environments it is not possible to install lsb on server machines as it will install tons of unneccessary rpms. Because of this we are stuck in 3.2 agent since it does not have this dependency. Please reconsider this in future releases.


  • With PAM 3.7, the dependency on LSB has been removed. The release can be expected around Nov-Dev 2019